Sn0wbreeze 2.3b2: Multitasking Gestures, iBooty/iBSS Fix for iOS 4.3 Jailbreak, MobileSubstrate

by on March 17, 2011
in Apple, iPhone




iH8sn0w has just released Sn0wbreeze 2.3b2 to jailbreak iOS 4.3 on iPhone, iPod Touch and iPad. A number of bugs have been fixed that includes: adding Multitasking Gestures option in Settings App, iBooty bug fixes, working MobileSubstrate etc.

Sn0wbreeze 2.3b2

Here is the full change log of Sn0wbreeze 2.3b2:

  • Adds Multitasking Gestures option in Settings App.
  • iBooty bug fixes (Includes iBSS issues).
  • iBooty is EVEN faster.
  • MobileSubstrate is now working.
  • Sleep bug in iPod Touches is fixed.
  • Rare iPad 1G issues resolved.
  • Added iREB to top bar for future re-runs within sn0wbreeze.
  • ultrasn0w is STILL broken! Unlockers STAY AWAY!

NOTE: This is just untethered jailbreak. Unlock for iOS 4.3 (iPhone 4 / 3GS) is NOT available!

Download Sn0wbreeze 2.3b2

You can download Sn0wbreeze 2.3b2 from here: Download Sn0wbreeze 2.3b2

Download iOS 4.3 for iPhone 4 / 3GS, iPad 2, iPad, iPod Touch 4G / 3G [Direct Links]

Was this post helpful? Follow us on Twitter (@SizzledCore) or become our Facebook fan for all the latest updates!


  • Betty

    iBooty still doesn't seem to work on my iPad, gets stuck at “waiting for device…” previously used to be iBSS.

  • Pingback: Download Sn0wbreeze 2.3: Fixes iPod Touch 4G iBooty Issues for Jailbreak iOS 4.3 on iPhone, iPod Touch, iPad | Sizzled Core()

  • Leon

    I get the exact same “Waiting for device” after “Exploiting with Limera1n” in iBooty, I'm also attempting a tethered boot on an iPad (4.3.1) after Restoring with custom FW with Sn0wbreeze 2.4b1. I dont' think it works with the iPad, from what I've read. Everything else but, unfortunately. Have you managed to find an alternative to iBooty, or a work-around to resolve this? Please let me know if you managed to get past this and successfully jailbreak. Desperate for a solution. Cheers

  • When the “Waiting for device” message is displayed, unplug the usb then plug it back in.